SU Animate Forum
Register  |   | 
 
 
 


Reply
  Author   Comment  
inferno2081

Registered:
Posts: 14
Reply with quote  #1 
I'm having an issue with doing multiple polyline path animations. In this particular case, I have a model that is moving along a path while also being rotated by other polyline path animations. When I originally build these animations, they work/preview correctly, but as soon as I hit the "Refresh" button in the SU Animate control dialog, one or several of these animations either gets completely deleted or gets turned into 3 separate animations with the same name. For example Path3 might become: Path1[Path3], Path2[Path3], and Path3[Path3]. Once this has happened, then sometimes new paths can't even be added.

I can't upload the model that I'm having this issue in, but i will try to build a simpler model that replicates the issue. In the meantime, is there a known bug with the refresh behavior?

Edit: Its also worth noting that when hitting refresh, SU Animate also seems to explode some of the groups involved in the animation.
davew

Moderator
Registered:
Posts: 180
Reply with quote  #2 
For two motions, the second path needs to be nested in the "parent" group/ component.   Is this what you are doing.  The wheel example here is a simple example -
http://www.suanimate.com/suanimate.php#zzee_link_12_1298693564

__________________
David Wayne
inferno2081

Registered:
Posts: 14
Reply with quote  #3 
Thanks for the reply. And yup, I'm definitely nesting the second motion path within the parent group. But that seems to be half the problem. To be clear, doing this type of nesting works fine, and the animation plays back in preview mode just like its supposed to until the "Refresh" button is pressed, then things break.

Fortunately, my secondary and tertiary motions are actually just rotations, so I've found I can use the arc path instead of a normal motion path, thus allowing me to keep the paths outside of the particular component/subgroups i'm trying to animate.

However, I tried recreating the problem in a new simpler model, and I was pretty successful at doing just that. I'm almost entirely certain that the refresh button breaks things when more than one motion path is used within a parent component/group. I keep getting the same problem described previously plus bug splats and an interesting issue where reopening the model causes arc paths to be disassociated from the elements they are intended to animate.
davew

Moderator
Registered:
Posts: 180
Reply with quote  #4 
We can look at the Refresh button but if you are doing more than one nested path in a component it general will not work.  For example, you can have a wheel rotating and moving forward but the wheel can not rotate, move forward and also move up and down. That's 3 motions and that will break the animation.  Not sure if that is what you are doing.
You can have 4 wheels all moving in the same direction though.  But the more complex the object animation gets, the more likely things are to break.  Can you upload the model so we can look at it?

__________________
David Wayne
davew

Moderator
Registered:
Posts: 180
Reply with quote  #5 
Upload is here -
http://www.suanimate.com/help.php

__________________
David Wayne
inferno2081

Registered:
Posts: 14
Reply with quote  #6 
I actually had several groups nested within each other, one group for each different motion path. So that with three separate motion paths the grouping went 3 deep. Now instead, I'm keeping the same grouping hierarchy but using arc paths since they don't have to be kept inside the group.

The model I'm uploading will have to have the arc paths re-associated with the appropriate groups. The groups and the paths that need re-associating have the same names for reference. Its just that every time I close this model and reopen it, the associations with the arc paths break.

On the upside, by using external arc paths, the refresh button doesn't seem to be breaking or exploding any groups, or doing the weird thing with deleting/renaming paths.

EDIT: the groups that need to be associated with the arc paths are in the "Car and markers" component
davew

Moderator
Registered:
Posts: 180
Reply with quote  #7 
At what point do you use the Refresh option. This is still in Preview mode right?
Is there a reason why you are using the Refresh?

__________________
David Wayne
inferno2081

Registered:
Posts: 14
Reply with quote  #8 
I had used the "Refresh" option after deleting paths various paths in the SU Animate main dialog. (It's not available when the animation preview controls are showing since you can't click on anything else but those controls).
davew

Moderator
Registered:
Posts: 180
Reply with quote  #9 
What I meant was you are not using Refresh after making scenes.  But it does not sound like you are.
__________________
David Wayne
inferno2081

Registered:
Posts: 14
Reply with quote  #10 
Yes, I haven't selected to make the scenes yet, in that sense its definitely still in preview mode.

Just checked again, and it appears the "Refresh" button also breaks the associates of the arc paths just the same as saving/closing/re-opening the document does.
Previous Topic | Next Topic
Print
Reply

Easily create a Forum Website with Website Toolbox.